Installation on Ubuntu 17.04

Hi

Each time I try to install the downloadable package (ZBA55A.bin) I get the following error message:

> ./ZBA55A_2.bin 
Preparing to install
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
      Verifying JVM...No Java virtual machine could be found from your PATH
environment variable.  You must install a VM prior to
running this program.

Which is strange, because I have set PATH and JAVA_HOME and both point to the Oracle JDK:

> echo $PATH
[...]:/usr/lib/jvm/java-8-oracle/bin:/usr/lib/jvm/java-8-oracle/db/bin:/usr/lib/jvm/java-8-oracle/jre/bin: [...]

(I shortended the path a bit, since there is also other unrelated stuff in it)

> echo $JAVA_HOME
/usr/lib/jvm/java-8-oracle

Also from attempting to read the shell script of the installer, I don’t quite get, how to circumvent it. Once I was able to install the last version (5.4I), which had the same issues, but unfortunatelly, I can’t find no clue, how I did it in the end.
The installation documentation (here: https://cdn2.hubspot.net/hubfs/488396/ZebraTester%20manuals/ZebraTesterInstallationGuide.pdf ) doesn’t help.

Any ideas?

Thanks and regards,
Daniel

Hi,

This might be a bug of the installation kit. Try to install and use Java 7 instead of Java 8.

1 Like

Per p29 of the Installation Guide, I believe it’s possible to get ZebraTester 5.5A working with Java 8 on Ubuntu, but this will mean all loadtest programs will be compiled with Java 8 and incompatible with ZebraTester installations on Java 7, including the Apica LoadTest Portal.

If possible, it may be more advantageous to install Java 7 alongside Java 8, and point the ZT installation to Java 7. This should be possible without affecting the existing Java 8 installation. I know of a number of users who have done this successfully on Ubuntu 14.04.

1 Like

Hi David, hi Duncan

Thank you for your replies. The installation of the official Java 7 is no longer possible, if you’re not an Oracle customer.
The following blog post of the team providing the de facto installation for Ubuntu and its derivatives highlights the issue:

Beside that, I’m sure, if you provide the appropriate sourc/target parameters prior to the compilation (the local Java setup, where you compile the tests), the result should be executable (but to be honest: I have not tested this, yet).

In the shell script, that’s part of the Linux installer, it’s mentioned, that there are means to be executable with Java 8. Also there is a lot of mentioning of a bundled JDK 7 - so in theory; i could somehow try to force to use that one instead of the locally installed (like on Windows). Any ideas how to do that?

Cheers,
Daniel

Hi all

Does anyone have any new ideas on this?

Daniel

Hi Daniel,

Yes, you can get it to work by explicity setting the jvm by using the LAX_VM variable. The specific command that worked for me was:
"sh ZBA55A.bin LAX_VM /usr/lib/jvm/java-1.8.0-openjdk-amd64/bin/java"
Of course, change the path to the correct one for your system.

HTH,
Per

1 Like

Hi Per

Great find!

The result is definitely something else:

./ZBA55A.bin LAX_VM /usr/lib/jvm/java-8-oracle/bin/java
Preparing to install...
./ZBA55A.bin: 1: ./ZBA55A.bin: grep: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: sed: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: sed: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: dirname: not found
/bin/ls: cannot access '': No such file or directory
./ZBA55A.bin: 1: ./ZBA55A.bin: basename: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: basename: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: sed: not found
The temporary install directory: 
     /tmp
does not exist or you do not have permission to write to it.
Please set the IATEMPDIR environment variable to a directory
to which you have the permission.
To set the variable enter one of the following
commands at the UNIX command line prompt before running this
installer again:

- for Bourne shell (sh), ksh, bash and zsh:

     $ IATEMPDIR=/your/temp/space/directory
     $ export IATEMPDIR

- for C shell (csh) and tcsh:

     $ setenv IATEMPDIR /your/temp/space/directory

./ZBA55A.bin: 1: ./ZBA55A.bin: expr: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: awk: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: tail: not found
./ZBA55A.bin: 404: ./ZBA55A.bin: awk: not found
./ZBA55A.bin: 435: [: closing paren expected
WARNING! The amount of /tmp disk space required and/or available
could not be determined.  The installation will be attempted anyway.
./ZBA55A.bin: 559: [: =: unexpected operator
Extracting the installation resources from the installer archive...
./ZBA55A.bin: 1: ./ZBA55A.bin: expr: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: expr: not found
./ZBA55A.bin: 749: ./ZBA55A.bin: rm: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: cksum: not found
./ZBA55A.bin: 1: ./ZBA55A.bin: awk: not found
The size of the extracted files to be installed are corrupted.  Please
try to download the installer again and make sure that you download
using 'binary' mode.
Please do not attempt to install this currently downloaded copy.

I recently had other issues with my system (lost all rights to access sudo, amongst others), so I guess I need to fix my installation prior trying to install the Zebra Tester!

Thanks a lot, I’m sure, that once I fixed that, your method will work!

Cheers,
Daniel